My OCD is kicking in


#1

Hey, quick question… Since I am manually aligning all of the audio and the video, I have a problemo. When I zoom in really close in Premiere, it starts jumping frame to frame and I can’t get it lined up exactly. I know the difference isn’t noticeable but is there anything I can do about it? Thanks


#2

Right-click on your sequence name, and then turn on “show audio time units.” This snaps you off the frame grid and lets you do sub-frame nudging! Turn it off to return back to frame-level editing.


#3

Thanks! I need 15 characters


#4

Hahah it took me a moment to figure out what you meant, but yeah, dang character minimums :stuck_out_tongue: